Astra Owners Network banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi Everyone,

My first post on this forum, and indeed any forum for a good few years!.

I have owned numerous Vauxhalls over the years, and the latest in a long line of VX tin, is my 2008 Zafira Elite 1.9CDTi 150. Overall, the car has been okay, but, coming from a Vectra 1.9CDTi 150 SRi NAV Auto, having to get used to a Gearbox and clutch that are potentially made of chocolate, is taking some getting used to :).

Anyway, I'm not adverse to tinkering, but, have had to entrust my more recent Vauxhalls to the dealer network, as they're still under warranty....thankfully, I have something old and 1980s based to keep my mechanical side entertained.

Anyway, at present, the car is in for an MOT, 10K service (I ignore the 20K flex servicing intervals) and a replacement Air Quality Sensor on the AC. I have recently had a perforated condensor replaced, and the system performed well, until recently.

A failed Air quality sensor was diagnosed and replaced. The compressor kicks in when the ECC is switched on, but, no refridgerant is circulated around the system, and despite having the sensor replaced, this is still the case.

The dealer techs are scratching their heads over it, so for my own curiosity, I am wondering if anyone has seen this before.

I know on other AC systems, there is an expansion valve near the evaporator, that opens to allow refridgerant into the Evaporator. Is it possible that this could be stuck shut, indeed does the Zafs ECC even have one.

The refridgerant pressure is spot on, the compressor kicks in, but no cold air or refridgeerant getting to the evaporator. No other sensors are registering a fault, but, I know this could be a red herring, as a fault sensor could be well within tolerance, but still faulty.

Any AC experts fancy having a guess at what is going on :)?

Thanks in advance,

James
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Hi All,

Just wanted to provide an update, and also a resolution to this issue.

ECC is a fairly rare option, apparently, and my setup, with the air quality sensor, is particularly rare. Thankfully, the fault on this occasion, was physical.

The compressor had given up, internally so had to be replaced. The clutch was permanently engaged, but no refridgerant was being circulated around the circuit, before the clutch would engage and disengage, if you activated or de-activated the AC, but, it soon became permantley engaged.

The compressor was replaced under warranty, but the actual job would be around £600, if carried out at a dealer.

- Autovaux will provide a compressor for £270 +VAT, the unit comes in a Delphi box, but, should be the same as the OEM item, I think they're Sanden compressors, anyway.
- If you do suffer a failed condensor, get it replaced ASAP, the longer you leave the system 'open' the more change you have of getting moisture into the circuit, which can cause issues, later down the line.
- When regassing, have the entire circuit vacuumed out and pressure tested, before regassing, this should hopefully minimise the chance of moisture contamination.

Annoyingly, the receiver/drier on the Zafira B, is apparently part of the condensor, and not a seperate part. If I had my way, this would've been replaced along with the compressor, as they can potentially catch any swarf, etc, from the compressor, if it happens to fail that way.

James
 
1 - 3 of 3 Posts
Top