Astra Owners Network banner

1 - 13 of 13 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I've been having a problem with my Opel GTC 2015, when I start the car after about 20 seconds the service vehicle soon screen comes up and then a couple seconds late, something that sounds like a fan starts. It normally stay like that for between 5-15min but it's increasing frequency and duration. The fan sound when the light is on is similar to the sound the car makes on a hot day after a long drive when you turn of ignition. Has anyone else had this problem and if so how'd they rectify it?? The service center could find anything.


Sent from my iPhone using Tapatalk
 

·
AON - Administrator
Joined
·
59,287 Posts
We need to know the engine to give an educated answer.

However, based on your description, my first guess would be 2.0 cdti which has a clogged DPF filter and needs a forced regen
 

·
Registered
Joined
·
433 Posts
If the Service Vehicle Soon (SVS) message appears then a fault code/s will be present. This needs to be read, diagnosed and an appropriate repair made. There was a problem with the thermostat on the petrol 1.6L and 1.8L that caused a SVS message and a continuous running fan. But to be sure the fault code, that will be present, needs to be read.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
1.6t petrol engine. No error code is present just SVS. my first reaction was to check the manual and look for solution.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #12
Just an update. Had the car serviced and they said the problem was with the thermostat. It's now been resolved.


Sent from my iPhone using Tapatalk
 
1 - 13 of 13 Posts
Top