Astra Owners Network banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1,229 Posts
Discussion Starter #1 (Edited)
Had this a couple of times now. Googling it reveals it happens on Insignia's as well.

First one was in approx. August last year, followed by a couple more occasions shortly afterwards. Along with the padlock symbol also being displayed, and car not starting. Obviously an immobiliser problem somewhere. Take key out of ignition, re-insert it and car starts fine. Message disappears, but the padlock symbol remained lit for approx. 5 mins.

Mentioned it a the last service in Sept 2015. The garage couldn't find anything and I was told to keep an eye on it.

Approx. 3 week ago I got the same message again. Not seen it since August last year, but thought I'd mention it again when it went in for servicing yesterday.

They think it's the key at fault (as a stored fault code said there was a key issue - P0513 immo key incorrect), so are ordering me a new one to be on the safe side. Quite fortunate really as the warranty runs out in 7 days :)

Shame I couldn't persuade them to replace the spare key (which is a non flip one) as well for a flip key :(
 

·
Moderator
Joined
·
3,890 Posts
Hope the new key sorts it. Let us know how it goes as it could be a useful reference for anyone else who gets the same problem.
 

·
Registered
Joined
·
1,229 Posts
Discussion Starter #4
I personally think it's an overkill replacing the key, seeing as it's only happened once in the past year, and a couple of times 13 months ago. I only mentioned it to them in case it ever became an issue when the car is out of warranty.

But hey ho, who am I to argue with the garage, when I'm getting a new key for nothing :)

Might ask for the old fob back, so I can convert my spare key into a flip one.
 
1 - 4 of 4 Posts
Top