Astra Owners Network banner
1 - 18 of 18 Posts

·
Registered
Joined
·
1,011 Posts
Discussion Starter · #1 ·
hey guys, prob saw my EGR thread, thought id make a new one as it doesnt seem to be that anymore. 56reg sport hatch 23k of mileage. Right has power issues. I had the EGR changed at 12k of mileage as the car was jerking, last 2k of mileage having loads more. Basically it doesnt happen all the time its intermitten which is the worse thing, i thought it did it in hot weather but that may not be the case. (this is all intermitten) can be sluggish generally, tends to be when im in lower revs in the lower gears just loses power, was stopped at roundabout and went to pull away and didnt do anything and then after about 6secs the revs picked up and turbo kicked in, its like the turbo isnt being allowed to "spool" up. It also did it earlier, going along in 3/4/5/6 generally sluggish, u know when u hit a big puddle and it slows u down its like that but on a milder scale, just does that like slowing u down, tends to be when constantly or taking foot slightly off accelerator and then back on, also did the slowly down thing constantly on the way down and generally being sluggish. It does this with or without the turbo kicked in but tends to be before 2k but seems the faster i go the worse the power issue gets cos its like it black spots n then its fine. Also the other nite went to overtake a 1.4 fiesta and could hardly overtake it :confused::sus: whats that all about? Taken it 2 different garages 3 times but cos its intermittent its sods law it doesnt do it, also mate took it out earlier and was fine and as soon as i drove it down the road it did it again, seems it doesnt like me! :( sorry for the essay guys, all garages apparently have tech2, taken EGR off, checked inlet manifold and its all fine, any guesses? much appreciated! sorry bout the long thread! :(:thumbs:
 

·
Registered
Joined
·
1,011 Posts
Discussion Starter · #4 ·
ooooo sorry! had it serviced about a month ago, checked the filter and oil earlier all fine! mines a diesel mat so dunno if it will be the same
 

·
Registered
Joined
·
10,190 Posts

·
Registered
Joined
·
1,011 Posts
Discussion Starter · #6 ·
lol i wouldnt know! EGR was changed at 12k of mileage the new modified one now done 23k nearly, so surely if the EGR has gone again then something is faulty to make it go wrong? and also when EGR went before no lights came up and none up atm, and apparently they checked it at the garage so surely its not the EGR, mines bog standard asin engine so dunno! :( and its not jerking its doing the hit puddle thing and no power so :S *confused and upset :(*
 

·
Registered
Joined
·
350 Posts
Swirl flaps? Haven't had the problem myself, but lot of people say that broken swirl flaps give the same effect as clogged EGR.
 

·
Registered
Joined
·
1,011 Posts
Discussion Starter · #16 ·
yeah apparently theyve looked at it all :( im gonna book it in when i get a chance n say i want inlet manifold and the EGR changed, just need the time off work AGAIN boss aint gonna be happy......:mad::'(
 

·
Registered
Joined
·
1 Posts
hey guys, prob saw my EGR thread, thought id make a new one as it doesnt seem to be that anymore. 56reg sport hatch 23k of mileage. Right has power issues. I had the EGR changed at 12k of mileage as the car was jerking, last 2k of mileage having loads more. Basically it doesnt happen all the time its intermitten which is the worse thing, i thought it did it in hot weather but that may not be the case. (this is all intermitten) can be sluggish generally, tends to be when im in lower revs in the lower gears just loses power, was stopped at roundabout and went to pull away and didnt do anything and then after about 6secs the revs picked up and turbo kicked in, its like the turbo isnt being allowed to "spool" up. It also did it earlier, going along in 3/4/5/6 generally sluggish, u know when u hit a big puddle and it slows u down its like that but on a milder scale, just does that like slowing u down, tends to be when constantly or taking foot slightly off accelerator and then back on, also did the slowly down thing constantly on the way down and generally being sluggish. It does this with or without the turbo kicked in but tends to be before 2k but seems the faster i go the worse the power issue gets cos its like it black spots n then its fine. Also the other nite went to overtake a 1.4 fiesta and could hardly overtake it :confused::sus: whats that all about? Taken it 2 different garages 3 times but cos its intermittent its sods law it doesnt do it, also mate took it out earlier and was fine and as soon as i drove it down the road it did it again, seems it doesnt like me! :( sorry for the essay guys, all garages apparently have tech2, taken EGR off, checked inlet manifold and its all fine, any guesses? much appreciated! sorry bout the long thread! :(:thumbs:
I had same problems with mine egr valve boost valve had inlet manifold de flapped goes like sh.. off a shovel. Pulls through all gears . 6th like 4th problem solved 👍
 
1 - 18 of 18 Posts
Top