Astra Owners Network banner

1 - 9 of 9 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Car: Astra 1.6 SXI 2001 Z16XE

I bought my car one year a go and seems to have had no end of things go wrong.

First to go was the starter motor (Feb) fixed

Then the revs started droppping and it was cutting out when slowing down, replaced EGR valve (May) fixed (but noticed some smoke when starting cold)

Then it started misfiring P0300 P0303, changed spark plugs and air filter (small improvement) changed coil pack fixed? (Aug) (bit more smoke when cold)

Had my mechanic mate change timing belt and water pump also changed oil and oil filter, running better than ever but still misfiring when idle I think and lots of smoke now when starting cold.

My mate did say centre section and back box will need changing within next 6months or so. Would the exhaust cause the smoking or could it be something else?

thank you for reading :zzz:
 

·
A.O.N - Approved Vauxhall Specialist (Anthony)
Joined
·
5,025 Posts
What colour is the smoke on start-up? How long does it smoke for? Does it smoke on hot re-start?
 

·
Registered
Joined
·
103 Posts
Discussion Starter #3
just a smokey grey colour i think can't get a proper look. Only smoke's for the first acceleration and haven't noticed any smoke when warm
 

·
Premium Member
Joined
·
1,023 Posts
bluey grey colour and I think it is still slightly misfiring
Seen as you have changed spark plugs and coil pack have you checked all the HT leads? Try tapeing them all up with insulation tape and see if this works? Hope you get it sorted (Y)
 
1 - 9 of 9 Posts
Top