Astra Owners Network banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello

My Z16XEP has failed its MOT in Emissions, high CO reading was the issue, HC and Lambda were fine. CO was all over the place high and low but never went below 0.2% to pass

The annoying thing is there is no EML, also in averaging around 37MPG so not using loads of fuel.

I have just got an OPCOM and set it up to read some live data. Everything i have read points to O2 sensors, MAF(if it had one), or some kind of over fuelling issue.

I have done some live data readings with my OBDII scanner and B1S1 o2 sensor is switching between 0.1v and 0.9v but seems a bit sluggish (switch around once every 1.5 seconds) but the B1S2 sensor is fluctuating with the front one and i have read this should be constant!

Based on this i have ordered a new front o2 sensor to fit and i plan to check the exhaust for leaks / tighten everything up, there is a slight whistle on the throttle body after cleaning so will tighten that as well.

Also it has an old K&N cone filter fitted as the top support bracket for the airbox snapped last time i took it out (the support that is sorta bolted onto the strut tower) and i cant for the life of me find a replacement to put the standard box back on, thinking the old dirty K+N might be restricting airflow?

Anybody got any other thoughts or wisdom for me to try before retest?

Thanks
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
That was worded terribly.

I have set up opcom on my laptop - and plan to read some live data (need guidance and what to monitor) and everything i have read on the internet points to O2 sensors, MAF(if it had one), or some kind of over fuelling issue.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
If the front o2 is commanding more fuel that is should due to long switching times would that cause the fluctuation? as its switching too slowly to maintain an even injector opening time?

Trying to avoid replacing the cat haha, although they are cheaper than i expected!
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Does anybody have any idea what the part number is for the airbox support bracket i mentioned?
 

·
AON Resident Cynic
Joined
·
14,669 Posts
That was worded terribly.

I have set up opcom on my laptop - and plan to read some live data (need guidance and what to monitor) and everything i have read on the internet points to O2 sensors, MAF(if it had one), or some kind of over fuelling issue.
It's actually against forum rules to help with using Opcom. The reason it a that it's pirated software that's been known to seriously damage cars (particularly when used for programming).

Is the car standard?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Yea the banana looking one with 2 rubber mounts on the ends.

Okay, dont worry about the opcom bit (sorry). The car is totally standard (that i know of) other than the temporary K&N filter.
 
1 - 9 of 9 Posts
Top