Astra Owners Network banner

1 - 20 of 23 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello all,

I am currently experiencing constant misfire under load. I have had issues with ignition components and been working through the system trying to get to the bottom of it. So far within the last 3 years I have done the following:-

  • Replaced Coilpack
  • Changed Spark plugs
  • Cleaned EGR
  • Replaced Front and Back O2 sensors (Had O2 sensor error come up)
  • Changed Spark plugs (again)
  • Cleaned Coilpack spark plug connectors
The EML light comes on and I now have the following error (OBD) P0302 - Cylinder 2 misfire.
When the engine revs over certain RPM the EML flashes and there is loss of power (it also sounds like a tank).
But strangely every so often the car starts running fine again, no misfire or hesitation, for maybe one drive (~35 miles to work each way) but then continues misfire again, so does this mean that the injector is ok and is likely to be ignition?

The car is a 52 plate 1.6 BiFuel (hasnt run on lpg in years).

Is it likely to be the coilpack again? Anything else I can check / test?

Thanks
zxsteve
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Can it be tested? Saw a utoob video once showing a coilpack and spark plug rested on engine and then turning engine over to see if it sparks. Will this work?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7 (Edited)
It might work but you already know it sparks as it runs OK some times. You will never be able to replicate the "on load" conditions with the plug out of the engine.
True!
Coilpack shopping it is then
Either of these OK?
http://www.eurocarparts.com/ecp/c/Vauxhall_Astra_1.6_2002/p/car-parts/ignition1/engine-parts/ignition-coil/?413720081&1&4f66b809fd25648c5016529c51b563de8ef2cf09&000197
or
http://www.autovaux.co.uk/product/19005212-1208037-ignition-coil-delphi-vauxhall-ope.aspx
Thanks
 

·
Registered
Joined
·
1,124 Posts
Rule out physical cylinder problems with a compression test and leak down test if low compression is found, if you don't get the right compression before the power stroke you'll get a misfire or incomplete combustion.
 

·
Moderator
Joined
·
3,890 Posts
I wouldn't worry about the coilpack being non-GM. My old 1.4 16v which my dad now has and his previous 1.4 16v before that have both gone through a few coilpacks and I found that the GM ones lasted 5 minutes whereas the non-GM ones have lasted longer. The current one is non-genuine and was purchased from www.vauxcentre.co.uk in 2008 and is still in good working order 8 years and 105,000 miles later. The two GM ones in the same car lasted 4 years and 3 years respectively. The 1.6 16v takes the same part (unless the bifuel is different).
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Well I bought a new coil pack. Misfiring all the way from work to pick it up. Chucked it in the boot and the immediately and I mean immediately it started working fine. It has now been driving without misfire or hesitation for a good few days!
Think my car has heard my idle threats about banger racing / scrap heap / trade in and has taken note. Still I'm gonna hang onto the coil pack for a week or so just in case!!
 

·
Moderator
Joined
·
3,890 Posts
Fitting a coil pack in the boot may not be the most conventional way to cure a misfire, but hey, if it works...! :lol:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #14
Spoke too soon!! Starred misfiring again. Fitted coil pack, replace plugs didn't do anything. Checked the coil pack was sparking the plug by resting on engine and it was! But put it back in and was misfiring without load this time.
What's next? I am getting seriously annoyed!
 

·
Registered
Joined
·
1,124 Posts
Sounds like your problem is a physical one ie something is happening inside your cylinders especially if your plugs are getting wet and oily, any smoke or steam from exhaust?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #19
Just come back from work and noticed at last mile or so the temp gauge reading 0. Checked for hot air in blower and it came out hot
As I come off motorway and changes down the revs dropped right of and started to cut out. Changed into gear and carried on OK. Then next gear change the car cut out. Had to use momentum to get car home.
Checked the hoses which were hot.
Now car starts but won't stay running. Cuts out after maybe 30 second!
Sound scr3w3d?
 

·
Moderator
Joined
·
3,890 Posts
Any new fault codes? I wonder if the ECU is receiving false information from sensors and is therefore unable to run the engine correctly.
 
1 - 20 of 23 Posts
Top