Astra Owners Network banner
1 - 19 of 19 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
My Son's 2010 Astra 1.4 SRI has an odd issue.

The Car runs great cannot fault it and it starts. (Good fuel MPG so engine is good)

1/. You unlock door and open door - Instrument panel is dead.
2/. If you sit with door open - now and then the door open LED flashes.
3/. if you turn on ignition - no change (but Headlights come on - when turned off).
4/. If you turn on ignition - and turn headlights to dipped beam the panel comes alive. (you can turn off lights and it is fine)
5/. The happens mainly when cold.

Works sometimes

1/. Click open door - open door light for door is lit and the back lights for Cluster. (perfect)

Have tried cleaning the pings on cluster.
Cleaned earths
Cleaned fuse box - pins under bonnet

not going to make suggestions on this one but where should I go next - My local Vauxhall dealer is just a parts cannon shop from my experience. Anyone know or recommend a good Auto electrician in Oxfordshire / Warickshire region? - car runs so can travel.

Get odd information from a OP-Com so not sure if I should believe that as well.

Thanks for any help or guidance
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #3 ·
HI Dave, I will try that and also charge battery for a bit (disconnect both + and -) Just this is a little odd. I will say when it works you hear a click in the car when it fails you hear nothing.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #4 ·
HI Dave, I will try that and also charge battery for a bit (disconnect both + and -) Just this is a little odd. I will say when it works you hear a click in the car when it fails you hear nothing.
Disconnected Battery - I did note that unlock car and pow it all works (instruments light up and good steady door open lamp). will leave off for an hour and then reconnect to see what happens next.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #5 ·
Disconnected Battery - I did note that unlock car and pow it all works (instruments light up and good steady door open lamp). will leave off for an hour and then reconnect to see what happens next.
OK reset for an hour - connected up and tested several start stops - locking car and unlocking it all appears to work fine now. But this needs time to settle in I think and be monitored for a bit.
In meantime - what tool do you think is a good one to buy just to help narrow this down? I have a opcom but do not trust it myself (always a beer half empty approach to these devices - as been bitten before)
 

·
Registered
Joined
·
1,352 Posts
Hmmm, my Chinese Opcom (before it died and stopped communicating with my laptop) gave the same fault info as the expensive diagnostic kit my local Vauxhall garage use. They wouldn't believe my diagnosis, so insisted on hooking it up to theirs and also charging me for the privilege!

My friends cheap ebay scanner (ELM327) that hooked up to an app on his phone didn't find anything.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
Why don’t you trust opcom, it will tell you exactly what’s wrong or at least point you in the right direction?

What’s it actually saying?


Sent from my iPhone using Tapatalk
It is just the OP-COM device I have "Cheap" and from what I have seen it is a good device just need to get a good one - looked on one site and it is close to £800 may as well look at a tech2 at that point.

On a Astra G I got odd characters back on it and a few other non-logical responses - I want to prove test equipment first like when doing electrical isolation's test equipment first, take readings and then test the equipment again.

Also heard if you do not take care some of these can ruin your car.
 

·
Registered
Joined
·
1,842 Posts
The biggest issue with most of the opcoms around now is that they use adulterated software
(often with parts added from later versions) and various hacked about "fake" firmware to match the copy chipsets they use,i certainly wouldn't recommend using one for any sort of programming.
There are decent clone opcoms about using standard software versions with genuine chipsets and original matching firmware.
You can pick one up if you know where to look,although they are considerably cheaper the the genuine version,don't expect ebay prices.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #12 ·
Thanks Gents - I am looking for a good OP-com now as after resetting the car the original issue has come back after a couple of trips. but the good news is if you turn headlights on pow-it works. So maybe will be able to set DLR on and issue will resolve itself?
So once I get a better Opcom I will dig deeper (and lucky I have 2 Vauxhauls to look at).
Also noticed the Instrument panel has been changed in the past.
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #14 ·
Thanks Gents - I am looking for a good OP-com now as after resetting the car the original issue has come back after a couple of trips. but the good news is if you turn headlights on pow-it works. So maybe will be able to set DLR on and issue will resolve itself?
So once I get a better Opcom I will dig deeper (and lucky I have 2 Vauxhauls to look at).
Also noticed the Instrument panel has been changed in the past.
have ordered one now so fingers crossed
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #15 ·
ok got and Op-com that appears to be giving better information for this issue as it has come back after resetting the car.
I can see the following errors;
Error CodeDescription
U2116-00CAN-Bus No Communication with IPC (Instrument)
U2206-00CAN-Bus No Communication with DIS (Digital
U2100-00No Communication with CAN-Bus
U2111-00CAN-Bus No Communication with EPS
B3925-00Wrong Environment Identifier Received IPC
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #16 ·
ok got and Op-com that appears to be giving better information for this issue as it has come back after resetting the car.
I can see the following errors;
Error CodeDescription
U2116-00CAN-Bus No Communication with IPC (Instrument)
U2206-00CAN-Bus No Communication with DIS (Digital
U2100-00No Communication with CAN-Bus
U2111-00CAN-Bus No Communication with EPS
B3925-00Wrong Environment Identifier Received IPC
Looks like an issue with CAN-Bus
 

·
Registered
Joined
·
262 Posts
Quite often one problem can cause multiple errors which can make it hard to diagnose the specific fault but at least gives you somewhere to start.

When you say you’ve reset the car, do you mean you’ve cleared all the fault codes?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #19 ·
HI Carlos - Reset = left battery off for 60 minutes (should reset the CAN-BUS). I cleared all DTC's as well and now left with 5 errors - but I think the worst on is the Power Steering cannot be communicated with. (it should be on the HS-CAN from what I can make out. )
Car runs fine, power steering is working as well. just now and then it has a bad moment (lights can go off a short while driving for a few seconds then back on again) - odd thing is once car is warmed up it is fine.
There maybe a few issues here hence one step at a time.
 
1 - 19 of 19 Posts
Top