Astra Owners Network banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi All,

If someone can help me decipher fault codes from pedal test.
I have 59 plate Astra Sri 1.8.
Done pedal test and got these codes and what I think they are having looked them up. (may be wrong? )
0097 - CAN- bus No comms with ECM
0116 - Coolant thermo valve open
3030 - fan control curcuit low voltage engine cooling
4810 - camshaft position solenoid valve
5976 - cylinder 3 misfire detected

Actual codes were
000970
059761
048106
001161
030301

I should add all came at once along with EML light, pulled over looked under the bonnet and found blue fuzz all around battery terminal.

Battery only 6 months old but fully charged it anyway.. And also replaced spark plugs and ignition coil..

If anyone can shed any light on this I would be extremely grateful.
 

·
Registered
Joined
·
5,340 Posts
Get the codes cleared and leave it a few days, see what codes come back, 1 or 2 may be historic


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
736 Posts
Davo just beat me to it lol
P0597-61 Coolant Thermostat Valve Stuck
P0481-06 Fan Control 2 Circuit Low Voltage
P0011-61 Intake Camshaft Phasing Mechanics Range/Perfomance
P0303-01 Cylinder 3 Misfire Detected
not sure on the first code you listed (000970) as i can't see any combination that's related to your engine,
as said, they need clearing and then see which come back
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thanks All for your help.

Here's where I'm at. Bought a code reader and read the codes. Only 1 of the 5 showed up on the obd reader, it was the 3030 one which as vala suggested is related to cylinder 3 misfire.

Not sure why it never showed all the codes from the pedal test??
I have cleared the code ( which actually came back as 'erase fail' on the device but still cleared the code as it was gone when searched again. Eml light went out within 20 seconds of starting the car and all seems well so far.. Makes me believe that 4 of the codes were historic as suggested by Davo, and the other was sorted once I changed the ignition coil.

I kkep you all updated if I have any more issues.

Cheers guys
 
1 - 4 of 4 Posts
Top