Astra Owners Network banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi guys just throwing this out there as it's a head scratcher for me, car is running bad especially when you want to put your foot down it just won't go, also my miles per galon has dropped massively, had camshaft sensors changed last year, just changed solenoid valves and post cat lambda sensor, and my pedal test is giving me no codes also my scanner giving me no codes. any ideas would be appreciated cheers.
 

·
Registered
Joined
·
1,443 Posts
Any idea what the engine is, and whether it requires petrol or diesel to propel it?

Also what figures were you previously getting to now?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Any idea what the engine is, and whether it requires petrol or diesel to propel it?

Also what figures were you previously getting to now?
hi mate, yes it's 1.6 petrol, was doing about 32 miles per galon or so, and now only doing about 22
 

·
Registered
Joined
·
1 Posts
Hi guys just throwing this out there as it's a head scratcher for me, car is running bad especially when you want to put your foot down it just won't go, also my miles per galon has dropped massively, had camshaft sensors changed last year, just changed solenoid valves and post cat lambda sensor, and my pedal test is giving me no codes also my scanner giving me no codes. any ideas would be appreciated cheers.

Hi,
I have had this problem with my Twin top 1.8L Z18XER down to 28MPG .at 36000 miles
Only diagnostic code I got was P010701 fuel trim running rich.
Replaced lambda sensor and fuel evac valve.
Hope this helps.
 
1 - 6 of 6 Posts
Top