Astra Owners Network banner

1 - 10 of 10 Posts

·
Registered
Joined
·
285 Posts
Discussion Starter · #1 ·
heres the problem........my heater blower doesnt seem to do anything on settings 1 -3..but works fine on 4....is this my motor or just my switch:(
 

·
Registered
Joined
·
13,581 Posts
From what I remember when I was looking into this (mine stopped working full stop) if it doesn't work 1-4 could be the fan, fuse, switch, wiring, lots of things like that... But if it works only on 4 it's a resistor... Sure someone will be along to confirm though (Y)
 

·
A.O.N - Approved Vauxhall Specialist (Anthony)
Joined
·
5,025 Posts
heres the problem........my heater blower doesnt seem to do anything on settings 1 -3..but works fine on 4....is this my motor or just my switch:(
Neither. ;)

Most likely the resistor is defective. You can find it by removing the glovebox, then following the two wires for the motor back towards the ducting, where you will find the resistor.

Be aware that the resistor usually blows for a reason, most common cause is the fan motor starting to seize up and draw too much current. Just replacing the resistor without sorting the cause of the problem could mean it blowing again in a short time.
 

·
Registered
Joined
·
675 Posts
mine did this soon after i bought it. £30 at the local breakers got me a new motor complete with resistor. Just a note of warning, mine blew because i had half a tree stuck in the pollen filter, may as well change that at the same time (Y)
 

·
Registered
Joined
·
3,928 Posts
Mine was caked with carbon from the brushes.
I took it to bits and blew out the carbon from the motor.
 

·
Registered
Joined
·
285 Posts
Discussion Starter · #10 ·
cheers people...shes booked in for mot on thurs so i may ask the garage to take a look....me and electrical things dont mix:)
 
1 - 10 of 10 Posts
Top