Astra Owners Network banner

1 - 14 of 14 Posts

·
Registered
Joined
·
918 Posts
Discussion Starter · #1 ·
Hi there,

As above, was driving and noticed that the battery light was on. Car is driving normally.
I have the following fault codes:
62102
161450
34029

Any help with the codes and what the problem is would be great.

Thanks
 

·
Premium Member
Joined
·
40,693 Posts
Don't know the first and last but

P1614 Immobiliser Wrong Signal Received Immobiliser B-008
P1614 Wrong Transponder Key Immobiliser B-006
 

·
Registered
Joined
·
2,032 Posts
P0621 Generator Lamp "L" Control Circuit Malfunction IPC (Instrument) C-021


P1614 Immobiliser Wrong Signal Received Immobiliser B-008
P1614 Wrong Transponder Key Immobiliser B-006

P0340 Camshaft Position Sensor Circuit Range/Performance C-008
P0340 Camshaft Position Sensor Circuit Open C-008
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #4 ·
Anybody know what them codes actually mean in real terms?

Don't understand the wrong immobilsor key one as I'm usin the same key as always and it opened an locked fine.
 

·
A.O.N - Approved Vauxhall Specialist (Anthony)
Joined
·
5,025 Posts
I would check the alternator is actually charging the battery, as that is your most pressing problem, and could leave you stranded if the battery is not being charged.

The 1614 code is quite common, and is usually due to a software 'bug' in one of the control modules.

The cam sensor code is *usually* due to a defective sensor, but there can be other causes.
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #6 ·
How would I find out if the alternator is charging the battery. Is it something a novice can do or would I need to take it to a mechanic?
 

·
A.O.N Assistant Regional Organiser - Scotland East
Joined
·
27,718 Posts
if you still have the factory fitted head unit, if you press and hold the settings button for about 10 seconds you should hear a beep, then by pressing the BC button you can browse the hidden menus on the screen, one of the menus has a battery voltage on it which should read between 11.5 - 12v when the engine is off and go up to around 14.5 with the engine on, if it doesn't go up of fails to go above 13v then the alternator is struggling to charge the battery, simples.
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #8 ·
I've got a standard head unit but it won't let me access the menu. I'm holding the setting button, says 'system' on the screen but doesn't beep or do anything different no matter how long I hold it for.

The battery light only comes on about 5 mins after driving. And goes off again if I turn the engine off. Don't know if that means anything?
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #9 ·
So....took the car to tht garage and it was confirmed that the alternator is fudged. So what is the average cost of getting this fixed. The garage is getting a price and is gonna ring me back so just wanted to know what's the average people have payed.

Cheers
 

·
Premium Member
Joined
·
59,287 Posts
For those who dont have access to the BC screens, a simple multimeter will give you a good indication. With the engine running use the multimeter to measure the voltage at the battery and compare against the figures suggested above
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #11 ·
with the engine running it was on 10.7 i think. so the mechanic suggested that i needed a new alternator. just rang me up and said he could refurb it for £180. so thats better than paying £250 for a new one plus fitting
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #13 ·
Yeah, I got there fine. He tested it and said he would check for prices. As I was about to leave, power steering died and instruments were dimming. So just left it there and should be done tomorrow
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #14 ·
Well the alternator went again the other day and has been repaired AGAIN!

I was stuck in traffic and as the battery was dying (I'm guessing this is what was happening) the lights were flickering, radio going on and off, speedo going off (revs and speed going to zero) power steering going on and off . I also got traction light, abs light, spanner light and engine management light flashing. I'm just wondering of that fairly normal if your battery is dying. Strange thing was that at no time did the battery light come on.

So what I'm wondering is was all these things being caused by the battery/alternator or could there be other reasons for this happening?
 
1 - 14 of 14 Posts
Top