Astra Owners Network banner

1 - 20 of 76 Posts

·
Registered
Joined
·
1,611 Posts
Discussion Starter #1
My 1.7 ecoflex returns a staggering 43ish to the imp gal , even with 6th gear engaged and cruise on. . Quite frankly , I'm disappointed. .:sus:
 

·
Registered
Joined
·
675 Posts
my rattling shed of a 1.7 (54) ZDTL returns an mpg of 58.9 average. i have had an average of 68mpg on a trip to scotland in June :)
 

·
Registered
Joined
·
15,498 Posts
1.9 8v with box and I average 53, got 64mpg on a recent trip to Somerset.

Saint, you'll need to give it time, mine didn't start giving decent economy until I'd done at least 5000 miles (Y)
 

·
Registered
Joined
·
1,611 Posts
Discussion Starter #8
It has got 24k on it , mate. I think there might be something wrong with it and I'd like to find out what , that , is. .:(
 

·
Registered
Joined
·
103 Posts
A lot of factors could cause low mpg the most common fault is the driver and the way they drive.I had a mondeo tdci before the j and if i ragged it it would give about 43 mpg but if drove sensibly would do 58! Not saying your a bad driver at all but the human factor is the big unknown in any mpg thread.Mechanically wise it could be a dodgy injector giving too much fuel which I have come across with the mondeo.
 

·
Registered
Joined
·
29 Posts
You don't state what kind of driving you do. I got 56.9mpg out of mine on a run to Harrogate that's at 70 with the cruise on. Avg just doing work runs and such is 48.
 

·
Registered
Joined
·
10 Posts
My 12month old 2L Astra J returns a little better than my old 1.9L Astra H estate. Around 42mpg. Not great tho I do little mileage. If I did a lot of miles then I would be very displeased I guess. About 7K on the clock after first service.
 

·
Registered
Joined
·
4,254 Posts
1.7CDTi, 100ps 5 speed box mapped to 150ps I was getting 42-43 if I drove it like I stole it. I would sit in 5th gear doing 80+ all the way from Glasgow to Bournemouth and get 52ish...? 60 If I was being sensible... Something isn't right there mate.. Check EGR, boost sensor, error codes..
 

·
Registered
Joined
·
654 Posts
It has got 24k on it , mate. I think there might be something wrong with it and I'd like to find out what , that , is. .:(

Mine was the same, it's a little better now and it's got 70k on the clock. The MPG on the new Astra is pants. I will be looking at a Leon next time.
 

·
Registered
Joined
·
1,611 Posts
Discussion Starter #14
You don't state what kind of driving you do. I got 56.9mpg out of mine on a run to Harrogate that's at 70 with the cruise on. Avg just doing work runs and such is 48.
You don't say what you are driving. .
 

·
Registered
Joined
·
469 Posts
My 1.7 ecoflex returns a staggering 43ish to the imp gal , even with 6th gear engaged and cruise on. . Quite frankly , I'm disappointed. .:sus:
Take it back:lol: My 2.0 cdti gtc returns 45-47 mpg with occasional spirited driving. Surprised you're not getting 50 mpg unless you have been putting derv in a petrol engine:sus:
 

·
Registered
Joined
·
91 Posts
Could be anything from incorrect tyre pressure or non standard wheels to dirty/faulty injector or dodgy ECU. Also the temp of the air will have an effect on mpg.

Either you're not having much luck with your car or it hates you :evil1:
 

·
Registered
Joined
·
3,928 Posts
Try setting up a poll for MPG for your car model and work out whether yours is normal,
a wee bit earier to interpret than everyone chipping in and you having to sift through the data.
 

·
Registered
Joined
·
1,611 Posts
Discussion Starter #20
Could be anything from incorrect tyre pressure or non standard wheels to dirty/faulty injector or dodgy ECU. Also the temp of the air will have an effect on mpg.

Either you're not having much luck with your car or it hates you :evil1:
Standard wheels but tyre size is 225 50 17. Think l might buy some fuel cleaner. .:(
 
1 - 20 of 76 Posts
Top