Astra Owners Network banner

1 - 13 of 13 Posts

·
AON - Administrator
Joined
·
59,287 Posts
What engine? Any other symptoms? Is it definitely the EML as opposed to the spanner light?
 

·
Registered
Joined
·
1,291 Posts
Hi
You will have to get a diagnostics check done on the car . The 1.6 is prone to coil pack failing, thermostat housing failing . I personally have had both and the o2 sensor B1 sensor 2 fail, as has my friend who also has the 1.6 j.
Have you also got the svs displaying in the centre.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Theres also no svs showing .it does come on every other month or so asking to service car soon im guessing thats just a reminder to take it in for a normal service
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
The lights gone out now im guessing its was a loose connection ?? .the m.o.t .is due next month so i will wait an c if they pick up on it .cheers
 

·
Registered
Joined
·
433 Posts
Theres also no svs showing .it does come on every other month or so asking to service car soon im guessing thats just a reminder to take it in for a normal service
Service Vehicle Soon (SVS) means that a fault has been detected. A fault code will be present and needs to be read (this is the service part), diagnosed and rectified.
A common problem with the early 1.6L J's is, as "redman" mentioned, a faulty thermostat housing. This gives an intermittent SVS message that gets steadily more frequent. This fault can also result in the radiator fan running continuously.

The message for annual service is "Change engine oil soon".
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
I havent had any codes appear on my central display so im a bit stumped .is there a way of getting the fault code up on the centre display .
 

·
Registered
Joined
·
433 Posts
The only way to read the fault code/s is with a suitable code reader. Previous GM models could display engine fault codes without a reader, but not the Astra J (Mk6) unfortunately.
When you originally said the EML was on, do you mean the symbol that looks like an engine?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Cool a will wait till the mot next month gonna be parked up for 2 weeks tommorrow anyway .thanks for the time .
 

·
Registered
Joined
·
2 Posts
i was driving my 2015 1.6 cdti ecoflex Astra j yesterday and suddenly I lost a lot of power and the engine light came on in amber, was 60 miles from home so stopped at the side of the road and did the ignition trick to get rid of limp mode because I had a few steep hips ahead of me and knew that in limp mode there’s no way I would have had the power to climb them, drove about 300 miles since with no issues other than the engine light still being on, a solid amber light no flashes or anything, any idea?
 

·
Registered
Joined
·
822 Posts
The MIL on steady indicates an emission fault,and as it's a diesel it could be DPF related or some other problem that wil stop the DPF regenerating,first step is a fault code read and progress from there.
 

·
Registered
Joined
·
2 Posts
About 2k miles ago I was driving it and a warning came up saying to drive until the car went into regenerations so I’ve had issues with that stuff in the past so I’m hoping that’s what it is, the car is on 97k and has incredibly poor service history and hasn’t been looked after at all so I’ve got a feeling it won’t be a simple fix
 
1 - 13 of 13 Posts
Top