Astra Owners Network banner

1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1 (Edited)
Hoping someone might be able to help with my 2011 Astra 2.0 CDti Dpf issue, recently clocked 56k miles.

6 weeks ago I was driving home from work and i suddenly lost power, the 'bong' noise sounded and 'service vehicle soon' came up on the display. I called the AA who plugged in and provided the Error code:
P2453 Diesel particulate filter differential pressure sensor Malfunction

I had the sensor replaced, the fault code cleared and the car returned to normal. Happy days so I thought.

3 weeks later the same limp mode kicked in, bong and 'service vehicle soon' came up on the display. My local garage then decided to check the dpf itself so off it came. One end was shiny and the other end was matt black which suggested a blockage. Rather than lump out £1,400 for a new dpf I sent the unit to DPF Clean Team. After the Clean Team confirmed it was blocked - airflow reading was 0.087, anything with a reading of 0.060 or more is apparently blocked and will not regenerate - they got in back to a 0.003 flow rate, i.e. as good as new.

Dpf back on the car, garage took it for a run down the dual carriageway but the same limp mode and error appeared again.

The replacement sensor fitted was an genuine GM part as I have heard aftermarket sensors are simply not worth it. My garage have now ordered another sensor to rule out the existing one being faulty which will be fitted on Monday.

Can anyone think of anything else as this is starting to cost a small fortune?

Thanks in advance,
Jonesy
 

·
AON - Administrator
Joined
·
59,287 Posts
Did anyone reset the DPF saturation reading? If not, the car still thinks the DPF is blocked and is trying to do something about it
 

·
Registered
Joined
·
21 Posts
Interested in this as well. Replaced the sensor, mechanic friend checked DPF and its fine but I got the same fault code over the weekend. I have a Delphi DS150e so I plugged it in and relearned the sensor and it's been working fine but I know it is likely to happen again in a few weeks. Had a check over the hoses tonight and couldn't see any issues.
 
1 - 6 of 6 Posts
Top