Astra Owners Network banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,341 Posts
Discussion Starter · #1 ·
Hi guys,right as title says...my gfs corsa c has had this problem for last 2 yrs,its had 5 new starters all changed through exchange for new ones, has been ok for last 12 months but started doing again other day,luckily i had a 2nd hand one which i bought from a scrappers that i knew had come from the exact same car,my friend...a mechanic ...changed it for me and worked fine...got the car home...left it for a couple of hours,went to start it......nothing but a loud clicking.

Thought maybe it was the battery so attempted to charge it but charger light came on after 3 seconds saying "100%" ???

My friend says the terminals and wiring all look fine but im still not completely convinced,when i go to start the car the dash and clock dim but only very slightly,im fairly certain that the starters ive had are ok and the battery is fine,i havent checked the voltage but the charger did say it was 100%.

My thinking is the wiring so i may either get them checked again and even take a stab and get them replaced.

Would like any other opinions,advice that can help me not lose too much money in finding the problem

Thanks guys/gals
 

·
Registered
Joined
·
10,531 Posts
Have you looked at starter solnoid? Or enen the ignition side of things?
 

·
Registered
Joined
·
1,341 Posts
Discussion Starter · #3 ·
Have you looked at starter solnoid? Or enen the ignition side of things?
Its had 5 new starters mate so ive ruled solenoids out as theyve all been new starters apart from one just fitted which was from a scrappers,tbh im not sure what makes up the ignition side of things but to me its starter,battery and wiring which could be the culprits....ive changed starter 5 times,tried charging battery but read 100%,so wiring seems next logical thing i guess
 

·
Registered
Joined
·
10,531 Posts
Try add a thicker ground wire to battery, starter and altenator then
 

·
Registered
Joined
·
1,341 Posts
Discussion Starter · #5 ·
Try add a thicker ground wire to battery, starter and altenator then
To me the alternator is fine as battery shows fully charged,starter should be fine as its had the same fault with 5 new starters,so just leaves wiring i guess
 

·
Registered
Joined
·
1,341 Posts
Discussion Starter · #6 ·
Sorry mate,i get what ya mean now by ya last post.....
 

·
A.O.N Assistant Regional Organiser - Scotland East
Joined
·
27,718 Posts
What voltage does the battery read over the terminals when not on charge?, don't test it just after charging or after switching off, wait about 30 minutes for the residual voltage to drop.

I know your saying it reads 100% but it could be that it's not holding the charge or not holding the voltage or producing enough volts to engage the starter, my dad's zaffy had that problem, alarm went off during the night for no reason and then wouldn't start, charged the battery and it started but withing a few hours started doing the same. Turned out the battery was past it and the voltage dropped to around 9-10v quickly after the car was switched off.

Sent from my HTC One X using Tapatalk 2
 
1 - 8 of 8 Posts
Top