Astra Owners Network banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys,

My son's Astra H keeps cutting out, the car will start again immediately no probs and could be ok again for a few hrs or even days but then this problem will repeat.

We have replaced the crankshaft sensor as we read this could be the cause of the problem, but the fault remains.

Normally, this would only happen when idling, however, today this happened whilst the car was in motion, albeit, this happened whilst the clutch was pressed and in the process of a gear change.

I have placed an opcom on the car and cleared the fault code list, but the following errors returned when the fault happened again:

Control Unit: 2006_Astra-H_Engine_Z 17 DTH

Total number of fault codes: 5

P1895 - Limp home - Limited Performance
(54) - Not present

P0500 - Vehicle Speed Signal Range/Performance
(74) - Not present

P2147 - Injector 1 or 4 Malfunction
(OF) - Not present

P2150 - Injector 2 or 3 Malfunction
(OF) - Not present

P0268 - Cylinder 3 Injector Circuit High
(OF) - Not present

My son has also mentioned that the car has never entered limp mode even though the fault code list stated otherwise, performance has never been lost.

Any ideas please on what would be worth investigating to resolve this issue please?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
We've ordered everything to do a full service on the car.

However, Last night my son was driving his car and noticed that the rev counter was not working.
Something in my mind is telling me this fault is related.

When the cutting out first started, we replaced teh camshaft sensor, but the fault did not go away and gradually getting more regular.

Somewhere I read says that the engine gets its revs from the alternator on this model, is this correct? The alternator has recently been changed and I don't recall him mentioning this fault before the alternator change. IIRC, the alternator was a refurbished, but is outputting the correct voltage to the battery when the engine is running (Ebay item 124330682976).

Only other sensor I can think of which would perhaps help would be the cam sensor.

Whats do you guys think please?
 
1 - 3 of 3 Posts
Top