Astra Owners Network banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Hi,

I recently brought a astra H life auto 05 plate Z18xe and noticed this problem on start up (see video attached), usually after sitting overnight. Does it intermittently then sometimes 2 days in a row. Yesterday and today are the the only times it revs like that without anyone sitting in the car. The engine is rocking but calms down and drives fine after.


Can anybody help with what the problem might be.
 

·
Registered
Joined
·
324 Posts
Worth giving your throttle body a good clean out, especially the small pin hole that connects up to the vacuum line. Whilst you are there, try to check for any split hoses, injector seals etc that could be letting in unmetered air. Do you have an fault codes stored?
 

·
Registered
Joined
·
161 Posts
Its not an induction leak as you have little backfires going on there.
I would say you have a bad leaking injector and fuel is going into the cyl when its not on a firing stroke. Hence the little pops.
Run it on a few tanks of V=Power and some STP Fuel Injector cleaner as well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Its not an induction leak as you have little backfires going on there.
I would say you have a bad leaking injector and fuel is going into the cyl when its not on a firing stroke. Hence the little pops.
Run it on a few tanks of V=Power and some STP Fuel Injector cleaner as well.
Timing belt was done recently, could it be out by a tooth, would that cause these symptoms?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Think I've sorted it. Gave the MAF sensor a good clean with electrical contact cleaner. If it comes back then I will swap it out.
 
1 - 6 of 6 Posts
Top