Astra Owners Network banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi,

I have a second hand astra convertible bertone 2.0 petrol car 2002. There are a couple of issues, which I'm beginning to wonder whether might all be related. Or, it might just be lots of things all going due to the age of the car!

Firstly, the boot does not work on the central locking. I have to use the key to open this up (which means if I ever drop anyone off I have to get our the car and open it for any luggage).

Secondly, the roof doesn't seem to respond to me pressing the button at all. No noises, no beeps. Just stays closed.

Thirdly, quite recently the car alarm has been going off randomly. This is only when I lock the car, so I've had to start leaving it open! Not ideal...

Finally, the heating / cooling buttons are only working half of the time and every now and then I get blasted as it seems to turn itself on. Maybe I have a car poltergeist. lol :sus:

A lot of issues now, and I need to start running through them and ideally have the hood issue fixed for summer (as this was the main reason for buying the car!).

Does anyone have any experience with this car and these issues? Could they all be related? I'm just wondering the best place to get started! I've seen a few notes about the ECU needing replaced, and also trying to manually open the roof (but also that this could cause more problems).

Appreciate any guidance!

Many thanks,
Cruizey
 

·
Registered
Joined
·
374 Posts
The hood n boot will most prob both same issue , in the boot running up pass hinge is a wirri g loom this tends to break over time from using the roof the continued action of opening closing stretches the loom till it snaps . Remove the inner panel on pass side in boot and if u can solder , solder about a 2" of fresh cable to the all the wires I the multi bock that u will find if any are broken.

I ha nt ever beard of a roof that hasnt made a sound though when failing to open so could it that the roof ecu has been disconnected? ??.

The alarm could b the powersounder that is under the inner arc plastic located near the door on pass side . The battery's die over time or it bas been known that if the printed curcuit on the rear screan is damaged this can also set the alarm off as it thinks the window has been broken.
 

·
Registered
Joined
·
2,691 Posts
Karl is right(Y)

No beeping sound when trying to operate the roof, means to me that some one has disconnected the system, to avoid the annoying beeping,

The roof ecu is located under the right hand side boot panel, Please look and come back.

B
 
1 - 3 of 3 Posts
Top